Apple Configurator Installation

Problem

Apple Configurator 2 will not install on my Mac?

Solution

The following operating systems are needed to use Apple Configurator, Mavericks, or higher. You will to download Apple Configurator 2 from Apple’s App Store. There is also an iTunes requirement to be on the latest version of iTunes.

See Moki in Action

Request a Demo today with by phone, email, or just fill out the form

Contact Us